<>RTX3080ti Pytorch踩坑指南

* 写在前面的罗里吧嗦
都说3080不支持cuda10, 可是复现前两年的代码,对应低版本的pytorch,可怎么跑呢?
经过亲身试验,安装cuda10,跑代码各种cuda相关报错。
比如
RuntimeError: CUDA error: CUBLAS_STATUS_EXECUTION_FAILED when calling
`cublasSgemm( handle, opa, opb
(解决方法:新建环境,pytorch官网pip安装。在最后)

最终找到了一条玄学之法。(仅个人经验)
如果在cuda110的上直接使用下面的命令装pytorch1.4.0,行不通。(来自pytorch官网)
(达咩)conda install pytorch==1.4.0 torchvision==0.5.0 cudatoolkit=10.1 -c pytorch

<>正经事

3080的服务器依旧安装cuda11。在anaconda创建环境时,直接创建对应环境的python,然后conda install
pytorch==1.X.X, 就可以。以下两个是我实验的。可以用,做个记录。

Python3.8-》 Pytorch1.4.0 -》 Cuda101

Python3.7 -》 Pytorch1.3.1 -》 Cuda100

小师弟说, 官网代码pip装也好使,这个我没试 ,好用!!!

(不是专业的,以上仅个人经验,勿喷)

技术
©2019-2020 Toolsou All rights reserved,
Python学习笔记(一)Linux【shell】 shell编程创建一个线程——— Javaweb (3)evo工具使用问题——Degenerate covariance rank, Umeyama alignment is not possibleVMware 16安装centos 7详细教程C语言做一个简易的登陆验证(功能)界面C语言——qsort函数Spring Boot面试必问:自动配置原理Android EditText密码显示隐藏Qt入门教程【基础控件篇】QCalendarWidget日历控件