win7 系统,同时安装了JDK7和JDK8,卸载了JDK8之后,cmd命令行输入:java -version
,本以为显示java版本1.7,结果弹错:has value '1.7',but '1.8' is required.

我查看JAVA_HOME,环境变量,发现也没有问题,指向的是C:\Java\jdk1.7.0

解决方法:

由于安装完JDK7之后,安装了JDK8,因为在安装JDK1.8时,自动将java.exe、javaw.exe、javaws.exe三个可执行文件复制到了C:\Windows\System32目录,由于这个目录在WINDOWS环境变量中的优先级高于JAVA_HOME设置的环境变量优先级。

明白这个后,就知道出错原因了,虽然卸载了JDK1.8,但C:\Windows\System32目录下的
java.exe、javaw.exe、javaws.exe三个可执行文件还是JDK1.8的,所以把JDK1.7的JAVA_HOME\bin下的这三个对应可执行文件复制覆盖到
C:\Windows\System32目录下,此时再在cmd命令行输入:java -version ,一切正常。

技术
©2019-2020 Toolsou All rights reserved,
排序(一)冒泡排序法一文揭秘阿里、腾讯、百度的薪资职级大数据告诉你,中国女人有多累年薪20万属于什么水平?答案让人扎心!面试的时候突然遇到答不上的问题怎么办?SpringBoot实践(五):mybatis-plus中的BaseMapper,Iservice和ServiceImpl这些歌,程序员千万万万万别听!python中解决字典写入列表的问题中台透彻讲解GDOI2019 游记